Office 365 - Some users may experience delays when sending or receiving email messages
Incident Report for Net Primates Ltd
Resolved
We have seen an improvement in sending and receiving email on the Office 365 platform. There has been no further reports of delays whilst sending and receiving emails and services have now gone back to normal operations.

If you are experiencing any further issues please email support@netprimates.com or contact us on 023 81 800 800 for further assistance.
Posted Jul 06, 2022 - 16:19 BST
Monitoring
We have been made aware by Microsoft that services should start to come back to normal. As they have identified that a section of infrastructure become unresponsive. Some users may still experience delays whilst services are being restored.

*******
User Impact: Users may have experienced intermittent delays when sending or receiving email messages in Exchange Online.

More info: Users may have seen message status' being stuck on 'Pending' or 'Getting Status'.

Final status: We've identified that a section of infrastructure, responsible for email attribution and routing, unexpectedly became unresponsive and resulted in DNS lookup failing to resolve hostnames. Additionally, this DNS issue prevented user traffic from being directed as expected and resulted in mail flow delays. We've rerouted user traffic to alternate infrastructure which restored the mail flow delays and remediated impact.

Scope of impact: Impact was specific to some users who were served through the affected infrastructure in Europe, Middle East, and Africa.

Root cause: A section of infrastructure, responsible for email attribution and routing, unexpectedly became unresponsive and resulted in DNS lookup failing to resolve hostnames. Additionally, this DNS issue prevented user traffic from being directed as expected and resulted in mail flow delays.

Next steps:
- We're analyzing performance data and trends on the affected systems to help prevent this problem from happening again.
Posted Jul 06, 2022 - 12:47 BST
Identified
We have been made aware that Microsoft are currently experiencing delays when sending or receiving email messages. We are seeing this impacting some of clients as well as Office 365 users not supported by Net Primates.

*******

User Impact: Users may experience delays when sending or receiving email messages

More info: Users may see the message status being stuck on 'Pending' or 'Getting Status'.

Current status: Microsoft are analyzing service telemetry information to determine the next troubleshooting steps.

Scope of impact: Impact is specific to some users who are served through the affected infrastructure in Europe, Middle East, and Africa.

Next Microsoft update by: Wednesday, July 6, 2022, 12:30 PM
Posted Jul 06, 2022 - 09:30 BST
This incident affected: Microsoft Office365 Platform.