Broadband Outage
Incident Report for Net Primates Ltd
Resolved
We have seen all of our customer circuits impacted by this event return to service at around 15:20

If you are still experiencing issues please do not hesitate to contact us via support@netprimates.com or 02381 800800
Posted Sep 10, 2021 - 15:45 BST
Identified
We have been made aware that one our broadband service partners is currently experiencing an outage impacting certain Broadband connections.

They are classing this a P1 incident with the next update due at 15:00
Posted Sep 10, 2021 - 14:42 BST
This incident affected: Broadband Network.