We have continued to monitor all afternoon and have seen no further reoccurrence of the issue.
Posted Apr 29, 2025 - 16:44 BST
Monitoring
The vendor has identified the cause of the outage and remediated the issue. We believe the issue has now been resolved and will continue to monitor, if you are still experiencing issues after a restart of your desktop/laptop please contact the Team on support@netprimates.com or call 02381 800800
Posted Apr 29, 2025 - 11:30 BST
Update
We are continue to investigate this issue however some initial remediation and resolution for users still experiencing the issue has been made by users restarting their desktop/laptop (not shutdown/sleep/reset) but restart.
We will continue to keep you updated.
Posted Apr 29, 2025 - 11:21 BST
Identified
We have identified the issue and speaking to other industry peers across other sectors globally they are experiencing the same issue.
We are working with the provider to get an estimated fix.
Posted Apr 29, 2025 - 10:47 BST
Investigating
We are currently investigating customers having issues with loading certain webpages and the perception that your Internet connection has gone down.
This issue that looks to be DNS related and we are working with the provider as a matter of priority.
Posted Apr 29, 2025 - 10:34 BST
This incident affected: Net Primates Cyber Protection Suite.