netprimates.com Website offline
Incident Report for Net Primates Ltd
Resolved
The webserver issue was resolved last night, our website is now fully operational.
Posted Jun 22, 2021 - 08:57 BST
Monitoring
We have been made aware by a web hosts that the webserver that hosts our website netprimates.com is offline.

They are currently investigating as a matter of priority.
Posted Jun 21, 2021 - 15:01 BST
This incident affected: Web Hosting.