Call Issues on the Voip Exchange Platform
Incident Report for Net Primates Ltd
Resolved
We have been advised that the issue has been resolved and test calls are confirming resolution.

If you are still having any issues please contact the support team on 02381 800800
Posted Jul 17, 2024 - 10:52 BST
Identified
We have started to receive increasing reports of customers on the Voip Exchange platform advising they are having call issues.

The platform provider is aware and is currently investigating.
Posted Jul 17, 2024 - 10:45 BST
This incident affected: Voip Exchange / Voxone Platform.